HobbyKing Forums
Forum Home Forum Home > Product Specific > Batteries & Chargers > Chargers
  New Posts New Posts RSS Feed: Connection Break Error IMax B6-AC
  FAQ FAQ  Forum Search   Calendar   Register Register  Login Login

Connection Break Error IMax B6-AC

 Post Reply Post Reply
Author
Message
  Topic Search Topic Search  Topic Options Topic Options
Hondo View Drop Down
Platinum  (CA)
USERID: 810410
Newbie
Newbie


Joined: 06/Apr/2011
Online Status: Offline
Posts: 7
  Quote Hondo Quote  Post ReplyReply Direct Link To This Post Topic: Connection Break Error IMax B6-AC
    Posted: 06/Apr/2011 at 10:47am
I have an IMax B6-AC bought from Hobbyking, for some reason when I try to charge My 3 cell and 2 cell lipos i get the "connection break" error while trying to balance charge using both sets of leads (i can do a basic unbalanced charge if i use the charge only feature and leave out the balance leads) BUT i bougt an Turnagy GT-Twin adapter when i got my charger that lets me use the 6 cell balance plug to charge 2 x 3 cells at once, the adapter is for Turnagy batteries specificaly and it works fine if i want to charge two 3 cells at once, all my 3 cell are Turnagy, so i think my 2 and 3 c3ll balance plugs on the charger are faulty and the 6 cell balance plug the adapter uses is not, "OR" there is more than on way to wire a JST-HX balance plug and the adapter by Turnagy fixes it for the Turnagy batteries on the Imax charger, I WOULD APPRICIATE A COMMENT FROM ANYONE WHO KNOWS IF THERE IS MORE THAN ON WAY TO WIRE THE JST-HX BALANCE CONNECTIONS AND TURNAGY BATTERIES MAY NOT BE COMPATIBLE WITH IMAX CHARGES OR IS MY CHARGER FAULTY AND HAVE BADE 2 AND 3 CELL BALANCE PLUGS?
Back to Top
Smith33 View Drop Down
Gold  (CA)
USERID: 871040
Newbie
Newbie


Joined: 26/Apr/2011
Online Status: Offline
Posts: 2
  Quote Smith33 Quote  Post ReplyReply Direct Link To This Post Posted: 26/Apr/2011 at 11:03pm
Have the same probelm with zippy 3s can not get to charge no matter what i try so sending back!! Had the same message in all lipo charge modes "connection break" argggg
Back to Top
mightymao View Drop Down
Platinum  (SG)
USERID: 755464
Newbie
Newbie


Joined: 07/Feb/2011
Online Status: Offline
Posts: 4
  Quote mightymao Quote  Post ReplyReply Direct Link To This Post Posted: 12/Jun/2011 at 11:16pm
Im having the same issue. im suspecting there may be a fault in the soldering on the battery.....  just cant open it up to check no circuity diagram.....
anyone got better suggestion
Back to Top
witooa View Drop Down
Platinum  (AU)
USERID: 57228
Newbie
Newbie
Avatar

Joined: 26/Aug/2010
Location: Australia
Online Status: Offline
Posts: 1
  Quote witooa Quote  Post ReplyReply Direct Link To This Post Posted: 05/Jul/2011 at 2:49pm
Yes I was having the same problem I read the info    hook the dean plugs up as well as the balance lead, I only used the balance lead (connection break) So try the 2 leads hookup, that hope that helps Allan
Back to Top
Sooty View Drop Down
Platinum  (NZ)
USERID: 173750
Hobbyking Addict
Hobbyking Addict
Avatar

Joined: 10/Mar/2009
Location: Christchurch NZ
Online Status: Offline
Posts: 4246
  Quote Sooty Quote  Post ReplyReply Direct Link To This Post Posted: 05/Jul/2011 at 5:15pm
You have either a voltage drop due to leads too long, bad solder joint, or broken balance lead or faulty connector block. Be careful using adapter plugs to convert from HXT to T connectors as these can drop the voltage and cause the error message. The balance leads can cause problems if you use the extension leads from HK in order to reach your lippo sack - a lot of these have oopsy connections.
Back to Top
beenflying View Drop Down
Platinum  (US)
USERID: 117556
Newbie
Newbie


Joined: 20/Feb/2010
Online Status: Offline
Posts: 2
  Quote beenflying Quote  Post ReplyReply Direct Link To This Post Posted: 06/Jul/2011 at 12:22am
I as well have the IMAX B6AC and the Hobby King ECO EIGHT balance chargers and both are giving me the connection error.I have tried different batteries,connecting the deans plugs and useing several of the hobbyking charging blocks with no success.The cost of shipping these back are too much.I also bought a ONYX230 advanced charger from my local hobby shop and i have the same thing.So this makes me want to believe that its someware in the battery packs that come from hobbyking.I have spent about a thousand dollars on chargers and batteries from hobbyking and my local hobby store which are ALL made in CHINA SO, i will be going back to my NIch Metal Cadium batteries and at least use the chargers for those.My last comment is DONY BUY FROM CHINA!!!!!!!!!!!!
Back to Top
mightymao View Drop Down
Platinum  (SG)
USERID: 755464
Newbie
Newbie


Joined: 07/Feb/2011
Online Status: Offline
Posts: 4
  Quote mightymao Quote  Post ReplyReply Direct Link To This Post Posted: 06/Jul/2011 at 2:00am
Well I open it up , clean it , check the voltage , continuity & resolder it back again.... still the same result..... F&^% .....
Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

Bulletin Board Software by Web Wiz Forums® version 9.54
Copyright ©2001-2008 Web Wiz

This page was generated in 0.219 seconds.